Back to overview
Degraded

EMAIL BLACKLIST

Dec 19 at 11:41pm GMT
Affected services
captain-vc.com

Resolved
Dec 27 at 12:15am GMT

We have marked the issue as resolved however the email server is still blacklisted and is unlikely to be resolved properly for a substantial amount of time. We are finding a solution in the meantime which works as email does not which will cause problems with user registrations to some services, updates from mailing lists bounce back and unanswerable support tickets. If you need to contact us please email captainorigami01@gmail.com which is Archie's email.

Updated
Dec 20 at 10:07pm GMT

The blacklists have been contacted - We can receive emails to our support line but cannot reply. Please visit https://capvc.3cx.uk/support in the meantime

Updated
Dec 20 at 11:51am GMT

The blaclist error has been identified and we will contact blacklists to remove us: https://spa.xfinity.com/postmaster?faq=comcast-mail-errors#BL000001

Created
Dec 19 at 11:41pm GMT

Emails from us may not land in your inbox, we are refraining from sending emails at this time. Please use our live chat feature in the mean time whilst the blacklists are removed. This is due to phishing sites using the same IP as the IP is shared across multiple people on our web host. We will update as we find out more