Back to overview
Some services are down
Jun 18, 2024 at 11:36pm UTC
Affected services
captain-vc.com
Resolved
Jun 21, 2024 at 06:28am UTC
Problem fixed
Affected services
Created
Jun 18, 2024 at 11:36pm UTC
SSL Certificate expired, new one not created automatically.
We are just verifying to make sure a new SSL is rolled out successfully.
Affected services